欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

macos10.8.5中安装metasploit

来源:本站转载 作者:佚名 时间:2013-10-27 TAG:metasploit 我要投稿

 macos10.8.5中安装metasploit

1.使用git下载最新metasploit

$ git clone https://github.com/rapid7/metasploit-framework.git

安装bundle

$gem install bundle

$cd metasploit-framework

$bundle install

 

安装过程中会提示以下错误

MacOS10.8.5中Ruby.framework默认是1.8.7,在执行bundle install的时候会提示factory_girl安装失败

h0ck3r:metasploit-framework sean$ sudo bundle install

Fetching source index from http://ruby.taobao.org/

Resolving dependencies…….

Using rake (10.1.0)

Using i18n (0.6.5)

Using multi_json (1.0.4)

Using activesupport (3.2.14)

Using builder (3.0.4)

Using activemodel (3.2.14)

Using arel (3.0.2)

Using tzinfo (0.3.37)

Using activerecord (3.2.14)

Using database_cleaner (1.1.1)

Using diff-lcs (1.2.4)

Installing factory_girl (4.2.0)

Gem::InstallError: factory_girl requires Ruby version >= 1.9.2.

An error occurred while installing factory_girl (4.2.0), and Bundler cannot continue.

[1] [2]  下一页

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载