欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

ADSL双线负载均衡设置详细图文教程

来源:转载 作者:佚名 时间:2008-07-14 TAG: 我要投稿

郁闷,,论坛不让写shuang线,我就用两线代替了...都不知道为什么要屏蔽shuang线....

首先说一下我为什么要用两条ADSL来代理上网.
本网吧开始用25M光纤带了400台机子,有一段时间感觉网络比较卡,于是老板考虑加带宽.
但是考虑到深圳的光纤费超贵的,就申请了两条4M的ADSL来分流..25M带340台,其它的60
台用两条ADSL来带..
(文章中我并不是带的60台,这个大家自己看)

为什么要用负载呢, 因为你用ROUTER OS接两个外网网卡,拔号上网以后,同
时能用的就只有一条ADSL,即使两条都拔上了也是这样.所以为了不浪费资源,我们就要负
载来让两条ADSL同时工作,同时来代理上网....
先引用一个高手的话.
--------------------------------------------------------------------------
注:很多人问
1.动态的ADSL怎么办?
你仔细观察一下IP Routes 里面 动态ADSL重拨IP是变的 网关是不变的
你在interfaces里的ADSL拨号 把Add Default Route 去掉
然后在IP Routes里手动添加网关
2.ADSL网关都一样怎么办?
简单嘛...其中一个Moden开启路由功能就就不同网关了不?
---------------------------------------------------------------------------
首先说一下ADSL分流大部分都是根据IP分流,或者是根据端口分流,由于我网吧的IP段
比较乱,我就根据IP分流来带60台机子..端口分流的话如果你喜欢可以自己试用一下.

我的ADSL拔号后的情况...我拔号后,每次网关都会变,,网关就是那次拔号后的
子网掩码.  那么应该怎么做呢? 往下看就是了..


第一步: 安装好routeros(我用的是2.927) 装上三个网卡,一个内网的,二个外网的..
        接好内网的网线,使你能访问路由...并且改好路由网卡的名称. 如图1



第二步:
外网(WAN1,WAN2)两个网卡添加pppoe client第一个命名为ADSL1 并且加上拔号的
        用户名和密码, 第二条命名为ADSL2 同时加上拔号的用户名和密码.这里要注意:
        把Add Default Route 去掉. 如图 2, 3






第三步: 设置IP伪装 这个大家都会吧...如图4,5





第四步: 设置MARK标记 标记你要分流的IP范围如图6,7设置new routeing mark为ADSL1,ADSL2




第五步: 在IP-routers中添加路由标记,命名为link1,link2这里的MARK要和你上一步中设的一致
        这里的gateway你可以随便填,因为下面会用脚本来更新这个路由. 如图8,9






第六步:
添加监控拔号状态的脚本,把拔号后得到的网关更新到上一步的路由表中...
        总共要加两个脚本. ADSL1,ADSL2 如图10,11 (system--scripts)







第七步:
添加一个计划任务,每隔10(或者是20)秒运行一下上面的ADSL1,ADSL2脚本.
        如图12,13 这里更改时间的话,就是interval后面改就行了,注意看图就OK了.
        (system--scheduler这个和XP中计划任务服务的名称是一样的.)




第八步: OK了,希望你能够成功...大家看看我做好以后的效果吧!!真实环境测试的.   

          下面是我的两条ADSL的真实流量图!


从今天早上做到今天晚上,终于搞定了。兄弟们觉得好的话就顶吧。。

提倡免费发贴,看贴回贴!!再次BS改掉我WG333网盘密码的那个人。


免费教给你东西,你还要改我网盘密码,太不厚道了。。打击我积极性。

下面再附上两条ADSL监控的脚本。大家直接复制就好了。如果你想自己熟悉一下内容
我还是建议你自己手动写下来。

ADSL1 的脚本

/interface pppoe-c monitor ADSL1 once do={:global pppzt $status}
:if ($pppzt=connected) do={/ip route set link1 gateway [/ip add get [/ip add find interface=ADSL1] network]} else={/ip route set link1 gateway [/ip add get [/ip add find interface=ADSL2] network]}

ADSL2 的脚本

/interface pppoe-c monitor ADSL2 once do={:global pppzt2 $status}
:if ($pppzt2=connected) do={/ip route set link2 gateway [/ip add get [/ip add find interface=ADSL2] network]} else={/ip route set link2 gateway [/ip add get [/ip add find interface=ADSL1] network]}

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载