欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

snort for snorby 入侵检测系统搭建

来源:本站整理 作者:佚名 时间:2017-05-09 TAG: 我要投稿

搭建一个入侵检测系统

简单介绍一下:Snorby是一个Ruby on Rails的Web应用程序,网络安全监控与目前流行的入侵检测系统(Snort的项目Suricata和Sagan)的接口。该项目的目标是创建一个免费的,开源和竞争力的网络监控应用,为私人和企业使用

1、在安装snorby之前,需要安装Ruby, ImageMagick, Rails 和 Wkhtmltopdf,安装包位置可以随便放。但是最好是要有一个统一的位置,比如/usr/local/src
yum -y groupinstall "Development Tools"
 yum install -y openssl-devel readline-devel libxml2-devel libxslt-devel mysql mysql-devel mysql-libs mysql-server urw-fonts libX11-devel libXext-devel qconf fontconfig-devel libXrender-devel unzip
2、下载安装ImageMagick,  和 Wkhtmltopdf
wget ftp://ftp.fifi.org/pub/ImageMagick/ImageMagick-6.9.8-4.tar.gz
Wget http://sourceforge.net/projects/wkhtmltopdf/files/0.12.1/wkhtmltox-0.12.1_linux-centos6-amd64.rpm/download

安装ImageMagick
tar -xvf ImageMagick-6.8.9-6.tar.gz
cd ImageMagick-6.8.9-6
./configure
make
make install
ldconfig /usr/local/lib

安装Wkhtmltopdf
需要先安装点东西
yum -y install xz urw-fonts libXext openssl-devel libXrender
rpm -Uvh wkhtmltox-0.12.1_linux-centos6-amd64.rpm

安装完了就可以测试一下
wkhtmltopdf http://www.qq.com qq.pdf
这里的意思是把qq的网页弄成pdf格式

3、安装Ruby
yum -y install libxslt-devel libxml2-devel gdbm-devel libffi-devel zlib-devel openssl-devel libyaml-devel readline-devel curl-devel openssl-devel pcre-devel git memcached-devel valgrind-devel mysql-devel ImageMagick-devel
yum -y install libyaml-devel
如果在安装的时候出现libyaml-devel问题,就安装下拓展
wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
说明:yaml是一种语法格式,很简单的,百度学习一下,很多地方会用到,比如saltstack

接下来使用RVM安装Ruby
curl -L get.rvm.io | bash -s stable
然后创建一个RVM环境
source /etc/profile.d/rvm.sh
这个时候RVM已经安装好了
可以测试看一下 rvm -v

接下来安装Ruby1.9.3版本,因为snort for snorby 有个要求ruby版本要求,Ruby >= 1.9.2, <2.x.x
rvm install 1.9.3
rvm use 1.9.3 --default

安装RubyGems
rvm rubygems current

这个时候,我们不安装rails,这个要进入到项目里

开始安装snorby
先安装一个Apache,并设置开机启动
yum -y install httpd
service httpd start
chkconfig --add httpd
chkconfig httpd on

然后运行 gem install bundler

接着,重点来了。
4、cd /var/www/html
然后登陆网页打开https://github.com/Snorby/snorby,里面有详细的说明,只不过没有详细说明步骤
先把内容给clone下来
git clone git://github.com/Snorby/snorby.git
这里要安装git,yum install  -y git

这里,要先进入数据库,创建一个用户,并授权
mysql -u root -p
create database snorby;
说明:这里的数据库可建可不建,建立了等等写库的时候会提示snorby已经存在,如果没有建,则会自动创建
创建一个可以登陆的用户,并授权
create user 'snorby'@'localhost' identified by 'snorby';
grant all privileges on *.* to snorby@localhost identified by 'snorby';
flush privileges;
Exit

编辑库的数据库配置文件
cp config/database.yml.example config/database.yml
上面写了是example,不会执行这个配置文件,所以需要改名
修改数据库的用户名密码,就是刚刚创建的用户和密码
这里的文件书写格式就是yaml格式的
vim config/database.yml
snorby: &snorby
  adapter: mysql
  username: snorby
  password: "snorby" # Example: password: "s3cr3tsauce"
  host: localhost
保存即可

还需要重命名snorby的配置文件
cp config/snorby_config.yml.example config/snorby_config.yml

接下来请注意:在这个地方会遇到非常多非常多的问题。
简单列下,会出现的问题和解决办法
1、要求你不要使用root用户进行安装,解决办法:这个只是警告,没有关系
2、提示缺少各种组件,一般是Jruby会有问题
   解决办法是把他们注释掉
    vim Gemfile
    # Jruby
    #gem 'jruby-openssl',               :platforms => :jruby
    #gem 'warbler',                     :platforms => :jruby
    #gem 'jruby-rack-worker',           :platforms => :jruby
# gem 'glassfish', :platforms => :jruby
还有会提示postmysql的问题,同样Gemfile,然后注释
#gem 'dm-postgres-adapter'
3、有时候会提示你ruby的版本问题,better_errors requires Ruby version >= 2.0.0,比如这样的。要>2.0.0,这里脑袋就大了,明明提示版本要求是Ruby >= 1.9.2, <2.x.x,可是这里却要求大于2.0.0,那要怎么办?

[1] [2]  下一页

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载