欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

两个Q号实现手机控制电脑

来源:本站整理 作者:佚名 时间:2016-11-02 TAG: 我要投稿

两个Q号实现手机控制电脑,而且手机只要能上Q,无需安装多余的APP!  也就是说,无论山寨机、智能机,只要能上Q,就可以实现手机控制电脑!!!  这个可是真的哦~

      先说下远控的原理:远控其实就像一个聊天软件,通过网络通讯实现互相信息的交流,只是远控分为控制端和被控端,控制端给被控端发送指令执行(指令是自己定义的,可以说是自己定义的协议) 实现这个功能的原理:首先要知道,腾讯有一个服务器是专门用于手机QQ,手机QQ通过发送数据到该服务器,再让服务器转发这个数据给对应的Q号(有点像聊天室的服务器),而对于这种数据的传输,腾讯也定制出了一种协议,我们把它叫做WAPQQ协议。我们可以在电脑上安装一个手机模拟器,让它在上面运行我们的QQ,然后通过抓包,我们可以分析出来它的协议(网上已经有不少大牛发了现成的协议,所以省去了分析的麻烦),同过分析,我们发现,其实WAPQQ协议是通过明文传输的,即不进行任何的加密,只是因为一些需要进行了编码的转换,到这里,我们是不是想到了什么?!!      嗯,没错,我们自己写一个PC版的WAPQQ,然后利用这个WAPQQ实现远控所做的事。
      我们PC版的WAPQQ所做的事:   先在程序上登陆我们的小Q(这里叫robotQQ),然后在我们的手机上登陆我们常用的QQ(当然电脑上也可以),当想要控制robotQQ的电脑的时候,我们给robotQQ发送对应的指令,robotQQ收到指令之后,按照指令,执行对应的事件,也就是我上面说的远控的原理。下面发下核心部分的代码:

.版本 2
.支持库 dp1
.支持库 iconv
.支持库 spec
.支持库 EThread.子程序 登录
.局部变量 计次, 整数型
.局部变量 文本, 文本型.如果 (客户1.连接 (“211.136.236.88”, 14000))
    标签状态.标题 = “正在登录...”
    .如果 (客户1.发送数据 (“VER=1.4&CON=2&CMD=Login&SEQ=” + 标记 () + “&UIN=” + 编辑框1.内容 + “&PS=” + 到大写 (取数据摘要 (到字节集 (编辑框2.内容))) + “&M5=1&LG=0&LC=812822641C978097&GD=5MWX2PF3FOVGTP6B&CKE=” + #换行符))
        标签状态.标题 = “发送登录数据成功!”
        编辑框1.禁止 = 真
        编辑框2.禁止 = 真
        按钮1.标题 = “退出登陆”
        处理事件 ()
        .如果真 (启动 = 真)
            .计次循环首 (取数组成员数 (授权Q号), 计次)
                文本 = “QQ机器人:” + 编辑框1.内容 + “  上线!”
                文本 = 到文本 (编码转换 (到字节集 (文本), #编码_GBK, #编码_UTF_8, ))
                .如果真 (授权Q号 [计次] ≠ “”)
                    延迟 (5000)
                    客户1.发送数据 (“VER=1.4&CON=1&CMD=CLTMSG&SEQ=” + 标记 () + “&UIN=” + 编辑框1.内容 + “&SID=&XP=C4CA4238A0B92382&UN=” + 授权Q号 [计次] + “&MG=” + 文本 + #换行符)
                    调试输出 (计次)
                .如果真结束            .计次循环尾 ()
            启动 = 假
        .如果真结束
        延迟 (5000)
    .否则
        标签状态.标题 = “发送登录数据失败!”
        客户1.断开连接 ()
    .如果结束.否则
    标签状态.标题 = “连接服务器失败!”
    延迟 (5000)
    _客户1_连接断开 ()
.如果结束
.子程序 _客户1_数据到达
.局部变量 返回文本, 文本型
.局部变量 类型_, 文本型
.局部变量 局部_好友帐号, 文本型
.局部变量 局部_临时文本, 文本型
.局部变量 局部_累积文本, 文本型
.局部变量 待处理文本, 文本型, , "100"
.局部变量 超长文本, 文本型, , "50"
.局部变量 文本长度, 整数型
.局部变量 计次, 整数型
.局部变量 循环次数, 整数型
.局部变量 授权, 逻辑型返回文本 = 到文本 (编码转换 (客户1.取回数据 (), #编码_UTF_8, #编码_GBK, ))
' 调试输出 (返回文本)
类型_ = 取指定内容 (返回文本, “&CMD=”, “&”)
.如果真 (寻找文本 (返回文本, “&UIN=” + 编辑框1.内容 + “&RES=20”, , 假) ≠ -1 且 类型_ = “Change_Stat”)

[1] [2] [3] [4]  下一页

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载