欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

WordPress WP Online Store插件本地文件包含和多个文件泄露漏洞

来源:本站转载 作者:佚名 时间:2013-03-11 TAG: 我要投稿

 受影响系统:

WordPress WP Online Store Plugin 1.x

描述:


BUGTRAQ  ID: 57963

WordPress WP Online Store插件可以将osCommerce eCommerce购物车集成到任何WordPress主题中。

WP Online Store 1.3.1在实现上存在安全漏洞,可被恶意用户利用泄露敏感信息。

1)index.php内的 "turl" 和 "file" 参数没有被正确验证即用于显示文件,通过目录遍历序列可造成泄露任意文件。

2)index.php内的 "slug" 参数没有被正确验证即用于包含文件,通过目录遍历序列可造成包含本地资源的任意文件。

<*来源:Charlie Eriksen
  
  链接:http://secunia.com/advisories/50836/
*>

建议:


厂商补丁:

WordPress
---------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://wordpress.org/extend/plugins/wp-online-store/

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载