欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

FFmpeg ff_dwt_decode函数拒绝服务漏洞(CVE-2015-8662)

来源:本站整理 作者:佚名 时间:2015-12-25 TAG: 我要投稿

受影响系统:

FFmpeg FFmpeg 〈 2.8.4

描述:


CVE(CAN) ID: CVE-2015-8662

FFmpeg是一个免费的可以执行音讯和视讯多种格式的录影、转档、串流功能的软件。

FFmpeg 2.8.4之前版本,libavcodec/jpeg2000dwt.c中函数ff_dwt_decode解码Discrete Wavelet Transform之前未验证分解层数,远程攻击者通过构造的JPEG 2000数据,利用此漏洞可造成拒绝服务(越界数组访问)。

<*来源:FFmpeg
  *>

建议:


厂商补丁:

FFmpeg
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.videolan.org/?p=ffmpeg.git;a=commit;h=75422280fbcdfbe9dc56bde5525b4d8b280f1bc5

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载