欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

Linux 内核 ipv4/udp.c 远程任意代码执行(CVE-2016-10229)

来源:本站整理 作者:佚名 时间:2017-04-15 TAG: 我要投稿


漏洞描述
Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。Linux kernel 4.5之前的版本中的udp.c文件存在安全漏洞,Linux内核中的udp.c允许远程攻击者通过UDP流量执行任意代码,这些流量会在执行具有MSG_PEEK标志的recv系统调用时触发不安全的第二次校验和计算,远程攻击者可精心构造数据执行任意代码,进一步导致本地提权,属于高危漏洞。但由于现实情况中,基于UDP协议的服务时MSG_PEEK标志在实际使用的情况较少,受该远程命令执行漏洞危害影响群体范围有限。
该漏洞是来自谷歌的Eric Dumazet发现的,他说漏洞源于2015年年末的一个Linux内核补丁。
漏洞编号
CVE-2016-10229
影响范围
依据CVE官网披露,当Linux Kernel版本小于4.5会受到该漏洞的影响。
Google Android受影响的发行版:Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player。以及其它相关的OEM版本。
Ubuntu 12.04、Ubuntu 14.04系列受影响,版本(16.04、16.10、 17.04)不受影响;
Debian 6、Debian 7、Debian 8系列均受影响;
SUSE 12和12SP1系列受影响;SUSE 12SP2 以及11及更早版本不受影响;
RedHat Linux 5、6、7系列不受影响;
修复方案
一些主要的Linux发行版,如Ubuntu和Debian早在今年2月份已经部署了修复后的build版本;Red Hat则表示,其Linux发行版不受该漏洞影响。谷歌方面在本月的Android安全公告中,也已经针对Android系统发布了相应的补丁。
厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=197c949e7798fbf28cfadc69d9ca0c2abbf931
建议存在该漏洞的企业按照自身业务情况,考虑受攻击面后酌情修复。
 

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载