欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

Samba信息泄漏破绽漏洞bug漏洞编号(CVE–2017–12163)提前预防公示

来源:本站整理 作者:佚名 时间:2017-09-22 TAG: 我要投稿

Samba作为Linux和UNIX体系上实现SMB协议的一个免费软件,在*nix范畴有很广泛的应用场景。
日前,360 Gear Team的安全研究员(连一汉,胡智斌)发现Samba SMB1协议存在安全缺陷,攻击者在具有Samba账户写入权限的情况下,能够远程走漏目标Samba服务器的内存信息,影响Samba全版别,缝隙编号为CVE-2017-12163。之后,Samba和Google团队提供了修正计划。
据悉,该缝隙被称为SambaBleed缝隙。
360CERT主张运用Samba软件的用户赶快进行安全更新。
0x01 事件影响面
影响等级
缝隙风险等级较高,影响规模较广
影响版别
Samba全版别
修正版别
Samba 4.6.8, 4.5.14 和 4.4.16
0x02 缝隙细节
在SMB1协议中,用户写请求的规模没有被严格检查,超越用户已发送的数据巨细,从而导致服务器的内存信息被写入文件,但是并不能操控哪些内存信息被写入。官方提供的补丁在写入之前加了请求写入数据巨细的判别,从而防御该缝隙。
走漏的内存信息:

0x03 修正计划
1、Samba 4.6.7, 4.5.13和4.4.15版别已提供官方补丁,强烈主张所有受影响用户,及时更新官方补丁,或者更新到已修正版别。
补丁地址:https://www.samba.org/samba/history/security.html 
2、强制运用SMB2协议,在smb.conf的[global]里设置"server min protocol = SMB2_02",并重启smbd。
 


 

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载