欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

访问服务好坏(QoS)的运作原理及关联技术

来源:本站整理 作者:佚名 时间:2017-09-13 TAG: 我要投稿
 
Router(config)# int f0/1            //在f0/1口应用CTS战略
Router(config-if)# service-policy output ysf2   
Router# show policy-map             //检查设置装备摆设战略
 
堵塞治理技巧
    堵塞治理一样平常采纳行列步队调剂技巧,经由过程行列步队调剂技巧的算法使得分歧的数据流领有分歧的优先级和带宽信息等,从而肯定分歧数据流被转发的次序和带宽。主要有如下六种技巧:
1.FIFO:先辈先出行列步队(只有一个队)
2.PQ:优先级行列步队(4个行列步队,高级别历久占用,出成绩)
3.CQ:定制行列步队(治理员可加,0保存,1--16轮轮回)
4.WFQ:加权公道行列步队(很多类,包小,优先级高,先发)
5.CBWFQ:基于类的加权公道行列步队(包管带宽)
6.CBLLQ:基于类低提早的加权公道行列步队(包管提早)
设置装备摆设CBWFQ
    跟着技巧的成长,最常用的是CBWFQ技巧
(1)界说婚配战略,与GTS、CAT第二种设置装备摆设雷同(略)
(2)界说 policy map 并挪用class map ,在每一个class map中设置战略

Router(config-pmap-c)# bandwidtn  {bandwidth-kbps | percent  percentage}
bandwidth:包管最小带宽
bandwidth-kbps:最小带宽速度(默许环境下,各class map 分派的带宽总和不克不及跨越接口带宽的75%,残剩的25%用于节制和路由抉择的流量。能够经由过程接口形式下的max-reserved-bandwidt 敕令停止改动)
percent  percentage:最小带宽占端口带宽的百分比
* 而后,设置装备摆设行列步队中数据包的个数

Router(config-pmap-c)# queue-limit  {packets}
packets:为设定的行列步队的数值,规模是1--4096
* 假如必要设置装备摆设默许类,可用如下敕令:

Router(config-pmap)# class  class-default
* 设置装备摆设LLQ行列步队的最大带宽

router(config-pmap-c)#  {bandwidth-kbps | percent  percentage}
priority:表现行列步队的最大带宽,其参数的寄义与bandwidtn敕令雷同
(3)在端口实行战略
与CRS、CAR的第二种设置装备摆设雷同,然则必要留意CBWFQ只能设置装备摆设在端口的output偏向
(4)相干检查敕令
show policy-map [policy-map-name]          //检查policy map 的设置装备摆设信息
show policy-map int f0/0          //检查端口的policy map信息和流量信息
试验案例:设置装备摆设CBWFQ,经由过程为PC1、PC2、PC3、PC4设置装备摆设最小包管带宽,办理收集堵塞成绩

(1)设置装备摆设收集全网互通(略)
(2)设置装备摆设CBWFQ,完成收集堵塞时包管最小带宽
R1(config)# access-list 100 permit ip host 10.0.1.2 host 10.0.0.4
R1(config)# access-list 101 permit ip host 10.0.1.2 host 10.0.0.1
R1(config)# access-list 102 permit ip host 10.0.1.2 host 10.0.0.2     //界说ACL
 
R1(config)# class-map match-all ftp1        //界说称号为ftp1的类
R1(config-cmap)# match access-group 100     //婚配ACL100的流量属于类ftp1
R1(config)# class-map match-all ftp2   
R1(config-cmap)# match access-group 101
R1(config)# class-map match-all ftp3
R1(config-cmap)# match access-group 102
 
R1(config)# policy-map ftp              //界说称号为ftp的战略
R1(config-pmap)# class ftp1             //进入类ftp1
R1(config-pmap-c)# bandwidth 4000         //为类ftp1设定战略,堵塞时带宽为4000Kb/s
R1(config-pmap-c)# exit
R1(config-pmap)# class ftp2
R1(config-pmap-c)# bandwidth 1600
R1(config-pmap-c)# exit
R1(config-pmap)# class ftp3
R1(config-pmap-c)# bandwidth 1600
R1(config-pmap-c)# exit
R1(config-pmap)# class class-default      //设置装备摆设其余流量为默许类
R1(config-pmap-c)# fair-queue            //启用公道行列步队,可和bandwidth同时应用
 
R1(config)# interface  f0/1
R1(config-if)# service-policy output ftp       //CBWPQ只能应用于output偏向
堵塞防止技巧
    适度的收集堵塞对付收集的迫害是很大的,堵塞防止便是自动抛弃部门报文,以减免收集堵塞水平
1.尾抛弃
    传统的丢包战略,即当行列步队到达最永劫,将后面的报文全体抛弃的战略。能够招致收集中流量忽大忽小,极不稳定
    在CBWFQ中设置装备摆设尾抛弃的敕令 queue-limit
2.WRED
    为防止呈现尾抛弃的征象,加权随机预检测(RED)将行列步队分为两个值,为低阀值和高阀值,并采纳如下算法:
* 小于低阀值时,不停止报文抛弃
* 大于高阀值时,完整抛弃报文
* 在低阀值和高阀值之间时,WRED开端停止随机抛弃报文。行列步队越长,抛弃的几率越高

上一页  [1] [2] [3] [4]  下一页

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载