欢迎来到 黑吧安全网 聚焦网络安全前沿资讯,精华内容,交流技术心得!

Ubuntu12.04使用Dotdeb安装PHP5.4 / Nginx1.4/Redis2.6等新版本

来源:本站转载 作者:佚名 时间:2013-09-08 TAG:linux 我要投稿

 众所周知,Ubuntu使用apt-get默认安装的软件版本都偏低,目前Ubuntu12.04安装的PHP版本为PHP Version 5.3.10-1ubuntu3.7,Nginx、Redis等常用软件版本也都非常保守。而这对于个人开发而言,要尝试新版本特性还需要编译安装解决依赖问题,实在不够方便。

Dotdeb就为Debian系提供了一个非常好的高版本更新源,由个人维护,但是更新非常快,使用Detdeb在Ubuntu12.04上就可以默认安装PHP5.4 / Nginx1.4 / Redis2.6等更新的版本。

用法也非常简单:

vi /etc/apt/sources.list 

在更新源中加入

#dotdeb deb http://packages.dotdeb.org squeeze all deb-src http://packages.dotdeb.org squeeze all deb http://packages.dotdeb.org squeeze-php54 all deb-src http://packages.dotdeb.org squeeze-php54 all 

然后添加密钥

wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | sudo apt-key add - 

就可以通过apt-get update更新了。

不过在实际使用中发现在安装php5-mysql等一些PHP扩展时报错依赖版本不够,要求libmysqlclient16 (>= 5.1.21-1),此时可能需要手动安装

wget https://launchpad.net/ubuntu/+archive/primary/+files/libzip1_0.9.3-1_amd64.deb sudo dpkg -i libzip1_0.9.3-1_amd64.deb

wget http://launchpadlibrarian.net/94808408/libmysqlclient16_5.1.58-1ubuntu5_amd64.deb sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_amd64.deb

目前使用Dotdeb在Ubuntu12.04安装的PHP版本为PHP Version 5.4.17-1~dotdeb.0

【声明】:黑吧安全网(http://www.myhack58.com)登载此文出于传递更多信息之目的,并不代表本站赞同其观点和对其真实性负责,仅适于网络安全技术爱好者学习研究使用,学习中请遵循国家相关法律法规。如有问题请联系我们,联系邮箱admin@myhack58.com,我们会在最短的时间内进行处理。
  • 最新更新
    • 相关阅读
      • 本类热门
        • 最近下载